Core services upgraded to Go 1.14

Greetings,

Hexabase core services now requires minimum Go 1.14 to develop and container deployments.

core services:

  • apicore
  • linkerapi
  • importer
  • notificator

Notable improvements of the upgrade is on the runtime. from https://golang.org/doc/go1.14#runtime

This release improves the performance of most uses of defer to incur almost zero overhead compared to calling the deferred function directly.
As a result, defer can now be used in performance-critical code without overhead concerns.

Goroutines are now asynchronously preemptible. As a result, loops without function calls no longer potentially deadlock the scheduler or significantly delay garbage collection.
This is supported on all platforms except windows/arm, darwin/arm, js/wasm, and plan9/*.